Проблем със SSL сертификат при Thunderbird след обновяване на Internet protection модул

Проблем:

  • Mozilla Thunderbird няма възможност да сваля нови мейли. Изписва съобщение "Checking mail server capabilities" в долният край на екрана.

  • Изпращането на имейли е възможно, но след като имейла се изпрати, се появява съобщение в Thunderbird, че изпратения мейл не може да бъде запаметен в локалната папка за изпратени съобщения.

Причина:

След ъпдейт на един от модулите на продуктите на ESET (Internet protection), се генерира нов root сертификат от страна на ESET. В  Thunderbird все още фигурира старият ESET сертификат и при включена SSL/TLS protocol filtering настройка, се получава несъответствие между сертификатите. На всяко устройство ESET пази частният ключ, който се използва с ESET root сертификата. Когато Thunderbird се опита да използва стария ESET root сертификат от своя Authorities store, съответстващия му частен ключ вече не съществува на самото устройство (тъй като е създаден нов частен ключ при генерирането на новия ESET root сертификат при ъпдейта на модула).

Решение:

Трябва да се добави новият ESET root сертификат към Authorities store на Thunderbird. За целта:

  1. Изтрийте старият ESET root certificate от Thunderbird.

  2. Спрете Thunderbird.

  3. Изключете и включете отново SSL/TLS protocol filtering в ESET решението

  4. Стартирайте Thunderbird

За да проверите дали двата ESET сертификата (този в ESET продукта Ви и този в Thunderbird) съвпадат сравнете сертификата в Advanced settings → Web and Email → SSL/TLS → Root certificate → View certificate:

И в Thunderbird от Options → Privacy and Security → Security → Manage Certificates:

 

 

 


 

 

 

Свързани материали: